Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^(1[012]|[1-9]):[0-5][0-9](\s)?([aAP][mM])$
/
Input 1
1
New
12:00 AM