package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:[^|]*[|]){2}([^|]*)`)
var str = `123|xx3|1x23|1x2x3|x123x|123x`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}