// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(?:(?<protocol>[^:/]+:))?(?::?\/\/)?(?:(?<user>[^/:]*)(?::(?<passwd>[^@]*))?@)?(?:(?<host>[\w._-]*))?(?::(?<port>\d*))?(?:(?<path>\/?[^?]*))?(?:(?<search>\?[^#]*))?(?:(?<hash>#.*))?$").unwrap();
let string = "https://user:pwd@localhost:6677/path/to/a/index.html?k1=v1&k2=v2#12313456";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}