// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi){#include\s*([\w.]+)\s*}").unwrap();
let string = "{#include header.html}
<header class=\"bg-gradient-to-r from-purple-700 to-indigo-800 shadow-lg w-full\">
<div class=\"max-w mx-auto px-4 sm:px-6 lg:px-8 py-6\">
<div class=\"flex flex-col items-center justify-between md:flex-row\">
<a href=\"/\">
<h1 class=\"mb-4 text-2xl font-bold text-white md:mb-0 md:text-3xl\">Header</h1>
</a>
<nav class=\"flex space-x-4\">
<a href=\"/\">
<a href=\"#\" class=\"text-white transition duration-150 ease-in-out hover:text-purple-200\">Home</a>
</a>
<a href=\"#\" class=\"text-white transition duration-150 ease-in-out hover:text-purple-200\">About</a>
<a href=\"#\" class=\"text-white transition duration-150 ease-in-out hover:text-purple-200\">Contact</a>
</nav>
</div>
</div>
</header>
<div class=\"flex flex-grow\">
<aside class=\"w-72 bg-gray-100 scrollable-column\">
<div class=\"p-6\">
<h2 class=\"mb-4 text-xl font-semibold text-gray-800\">Directories</h2>
{#each item in dirs}
<div class=\"mb-3\">
<a href=\"{item.link}\"
class=\"font-medium text-indigo-600 transition duration-150 ease-in-out hover:text-indigo-800\">{item.name}</a>
</div>
{/each}
</div>
</aside>
<main class=\"flex-grow bg-white scrollable-column\">
<div class=\"p-6 md:p-8\">
{#each item in files}
<div class=\"space-y-4\">
<div class=\"flex flex-col sm:flex-row border-b-2 border-gray-200 pb-4\">
<div class=\"w-full sm:w-[150px] h-[150px] border-2 border-black flex items-center justify-center overflow-hidden mb-4 sm:mb-0 flex-shrink-0\">
<a href=\"{item.link}\">
<img src=\"{item.image}\" alt=\"thumbnail\" class=\"w-full h-full object-cover\">
</a>
</div>
<div class=\"flex-grow pt-2 sm:pl-4\">
<h3 class=\"mb-2 text-xl font-semibold\">
<a href=\"{item.link}\"
class=\"text-indigo-600 transition duration-150 ease-in-out hover:text-indigo-800\">{item.name}</a>
</h3>
<p class=\"text-black text-sm -mt-2 mb-2\">{item.date}</p>
<p class=\"text-gray-600 text-lg\">{item.summery}</p>
</div>
</div>
</div>
{/each}
</div>
</main>
</div>
<footer class=\"bg-gray-800 text-white\">
<div class=\"container mx-auto px-4 py-8\">
<div class=\"flex flex-col items-center justify-between md:flex-row\">
<div class=\"mb-4 text-2xl font-semibold md:mb-0\">Footer</div>
<div class=\"flex space-x-4\">
<a href=\"#\" class=\"transition duration-150 ease-in-out hover:text-purple-300\">Privacy</a>
<a href=\"#\" class=\"transition duration-150 ease-in-out hover:text-purple-300\">Terms</a>
<a href=\"#\" class=\"transition duration-150 ease-in-out hover:text-purple-300\">Contact</a>
</div>
</div>
</div>
</footer>
{#include footer.html}
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}