# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?s)\[sometag\](.*?)\[\\/sometag\]/$1/gm;t' <<< "[sometag] here is more text
it spans more than one line [/sometag]
[sometag]this is a bit of text[/sometag]"