#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?s)\[sometag\](.*?)\[\/sometag\]"
Local $sString = "[sometag] here is more text" & @CRLF & _
                "" & @CRLF & _
                "it spans more than one line [/sometag]" & @CRLF & _
                "" & @CRLF & _
                "[sometag]this is a bit of text[/sometag]"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)