using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)\[sometag\](.*?)\[\/sometag\]";
string substitution = @"$1";
string input = @"[sometag] here is more text
it spans more than one line [/sometag]
[sometag]this is a bit of text[/sometag]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}