const regex = /(?s)\[sometag\](.*?)\[\/sometag\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)\\[sometag\\](.*?)\\[\\\/sometag\\]', 'gm')
const str = `[sometag] here is more text
it spans more than one line [/sometag]
[sometag]this is a bit of text[/sometag]`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);