# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?s)\[sometag\](.*?)\[\/sometag\]"
test_str = ("[sometag] here is more text\n\n"
"it spans more than one line [/sometag]\n\n"
"[sometag]this is a bit of text[/sometag]")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.