re = /(?s)\[sometag\](.*?)\[\/sometag\]/m
str = '[sometag] here is more text
it spans more than one line [/sometag]
[sometag]this is a bit of text[/sometag]'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result