import Foundation
let pattern = #"(?s)\[sometag\](.*?)\[\/sometag\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[sometag] here is more text
it spans more than one line [/sometag]
[sometag]this is a bit of text[/sometag]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)