const regex = /\[b\](.*?)\[\/b\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[b\\](.*?)\\[\\\/b\\]', 'gm')
const str = `[b]foo[/b]foo[b]bar[/b]`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);