using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"A{4}\([a-zA-Z]{4},\d\)";
string input = @"AAAA(abcd,6)
AAAA(WXYZ,2)
AAAA(abcd,6,9)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}