import Foundation
let pattern = #"A{4}\([a-zA-Z]{4},\d\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
AAAA(abcd,6)
AAAA(WXYZ,2)
AAAA(abcd,6,9)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)