$re = '/(^((?!dish).)*$)/m';
$str = 'test
words
more words test dish
&test good
words and test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);