#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+\.\d+\s+\d+\:\d+"
Local $sString = "02.01 13:00 выполнено" & @CRLF & _
"01.01 12:00 выполнено" & @CRLF & _
"01.01 12:00 выполнено 1" & @CRLF & _
"02.01 13:00 выполнено 2" & @CRLF & _
"01.01 12:00 выполнено 9" & @CRLF & _
"02.01 13:00 выполнено 10" & @CRLF & _
"01.01 12:00 выполнено 15" & @CRLF & _
"02.01 13:00 выполнено 16" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")