const regex = /\/(?=\d*[A-Za-z])(?=[a-zA-Z]*\d)[A-Za-z0-9]{10,20}\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/(?=\\d*[A-Za-z])(?=[a-zA-Z]*\\d)[A-Za-z0-9]{10,20}\\b', 'gm')
const str = `<73010825822784709>d
https://youtube.com/abcDeFg1234
https://youtube.com/abcDeFg1234|`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}