# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\D+_//gm;t' <<< "name_001.png
na-m-e_001_tr.png
name_name_001.png"