re = /^\D+_/m
str = 'name_001.png
na-m-e_001_tr.png
name_name_001.png'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result