re = /'([^']*)'\s*(?=\bis\b)/
str = 'RECOVERY: \'XXXXXXXXX\' is UP
PROBLEM: \'ABABABAB\' on \'XXXXXXXXX\' is WARNING
PROBLEM: \'XXXXXXXXX\' is DOWN
RECOVERY: \'ABABABAB\' on \'XXXXXXXXX\' is OK
PROBLEM: \'ABABABAB\' on \'XXXXXXXXX\' is DOWN'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end