Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
[^0-9a-zA-Z]+
/
gm
Input 1
1
New
Hiaity) **earthquake 2010 @#$%%^&*()_+ 2010 Haiti Earquake
Substitution