const regex = /\b(longword1|longword2|longword3)\b.*?\b(?!\1\b)((?1))\b.*?\b(?!(?:\1|\2)\b)(?1)\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(longword1|longword2|longword3)\\b.*?\\b(?!\\1\\b)((?1))\\b.*?\\b(?!(?:\\1|\\2)\\b)(?1)\\b', 'gm')
const str = `A longword1 B longword2 C longword3 D
^--------------------------------^
A longword2 B longword1 C longword3 D
^-------------------------------^
A longword3 B longword2 C longword1 D
^-------------------------------^
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}