const regex = /^([^.0-]\d+|\d)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^.0-]\\d+|\\d)$', 'gm')
const str = `111111111111111999999999999999990000000000000000333333333333333332
10
11
2
00
-1
-22
.5
1.4
0.1
0.
0-
-0
000.4
022345
0
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);