package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`0[5-6][0-9]{8}`)
var str = `0599999987`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}