$re = '/0[5-6][0-9]{8}/';
$str = '0599999987';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);