$re = '/^[a-zA-Z0-9_.]+@[a-zA-Z0-9_.]+$/m';
$str = 'foo@bar.com
bar@foo.com
far@boo.com
foo.bar@bar.edu.fr';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);