import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^,]*),([^,]*),([^,]*),(.*)";
final String string = "StreetA @ StreetB,1 NameA,DirectionA,Lat,Long\n"
+ "StreetC @ StreetD,1 NameA,DirectionA,Lat,Long\n"
+ "StreetE @ StreetF,1 NameA,DirectionB,Lat,Long\n"
+ "StreetG @ StreetH,1 NameA,DirectionB,Lat,Long\n"
+ "StreetI @ StreetJ,2 NameB,DirectionC,Lat,Long\n"
+ "StreetK @ StreetL,2 NameB,DirectionC,Lat,Long\n"
+ "StreetM @ StreetN,2 NameB,DirectionD,Lat,Long\n"
+ "StreetO @ StreetP,2 NameB,DirectionD,Lat,Long";
final String subst = "$2 - $3=[[$1,[\\4]]]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}