const regex = /([\s=\/:@#$*|,;'"\\(\[{}\)\]<>._-]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\s=\\\/:@#$*|,;\'"\\\\(\\[{}\\)\\]<>._-]+)', 'gm')
const str = `9Ap6O8#9RGZ8UNh4u1F}V0ryRLSDZRz4@58#\$q
lu:0\$G#t;GEEyb Iqq7Mg;Se;TVTgH":tc[iik*2
d(m/hQ3F*r0Rot9#UX tS9y\\kDu'FOst/Z}<Rvat"
tXl.0sVYai;eQVBq*cookies&cream:Qt;zV2{Bdh.E`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}