import re
regex = re.compile(r"([\s=\/:@#$*|,;'\"\\(\[{}\)\]<>._-]+)", flags=re.MULTILINE)
test_str = ("9Ap6O8#9RGZ8UNh4u1F}V0ryRLSDZRz4@58#$q\n\n"
"lu:0$G#t;GEEyb Iqq7Mg;Se;TVTgH\":tc[iik*2\n\n"
"d(m/hQ3F*r0Rot9#UX tS9y\\kDu'FOst/Z}<Rvat\"\n\n"
"tXl.0sVYai;eQVBq*cookies&cream:Qt;zV2{Bdh.E")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")