package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-HJ-NPR-Z\d]{8}[\dX][A-HJ-NPR-Z\d]{8}$`)
var str = `1FUYDMDB2YPF87097
1FAHP26W49G252740
WP0CA29863U153381
2FTRX07W53C371582
1FAHP26W49G252740
WP0CA29863U153381
2FTRX07W53C371582
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}