const regex = /^[A-HJ-NPR-Z\d]{8}[\dX][A-HJ-NPR-Z\d]{8}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-HJ-NPR-Z\\d]{8}[\\dX][A-HJ-NPR-Z\\d]{8}$', 'gm')
const str = `1FUYDMDB2YPF87097
1FAHP26W49G252740
WP0CA29863U153381
2FTRX07W53C371582
1FAHP26W49G252740
WP0CA29863U153381
2FTRX07W53C371582
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}