// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-HJ-NPR-Z\d]{8}[\dX][A-HJ-NPR-Z\d]{8}$").unwrap();
let string = "1FUYDMDB2YPF87097
1FAHP26W49G252740
WP0CA29863U153381
2FTRX07W53C371582
1FAHP26W49G252740
WP0CA29863U153381
2FTRX07W53C371582
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}