using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/user/(?P<user>[^/]+)/(?P<action>[^/]+)";
string input = @"/user/someone/news";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}