import Foundation
let pattern = ##"^https://docs\.python\.org/\d/[^#]*$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
https://docs.python.org/3/library/foo.html
https://docs.python.org/3/reference/foo.html#some_hash
https://docs.python.org/3.6/using/foo.html
https://docs.python.org/3/#extension1
https://docs.python.org/2/library/bar.html
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)