#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.*)[.]([0-9]{1})(b|B)([0-9]{1,2})[.](.*)$"
Local $sString = "abcd.1B21.efg.hi.txt" & @CRLF & _
"abcd.1b21.efg.h2i.txt" & @CRLF & _
""
Local $sSubst = "$1.0$2b$4$5"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)