import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(0|[1-9][\\d]*)\\h+(?:@?((?<=@)[^@]+(?=@)|(?!@))(?:@\\h+)?)(?<Special>FAM[SC]|CHIL)?(?(Special)|(?<NoSpecial>\\w+))(?(Special)\\h+@([^\\v]*|)@|\\h*([^\\v]*|))";
final String string = "0 @Reference@ Objekt\n"
+ "1 NAME Max /Mustermann/\n"
+ "2 DATE 22 APR 2016\n"
+ "1 FAMC @I123@\n"
+ "1 FAMS @I124@\n"
+ "1 CHIL @I125@";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}