use strict;
my $str = '/wp-content/themes/scaffold/css/sidebar.css?ver=4.9.4
/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.9.6
/wp-content/themes/scaffold/css/sidebar.css?ver=4.9.6
/wp-content/plugins/wp-ultimate-csv-importer/assets/css/style-maintenance.css?ver=4.8.1
/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.9.2
/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.9.6
/wp-content/themes/scaffold/css/sidebar.css?ver=4.9.6
/wp-content/themes/scaffold/css/sidebar.css?ver=4.9.2
/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.14
/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.9.5
/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.9.4
/wp-content/themes/scaffold/css/sidebar.css?ver=4.9.5
/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.8.2
/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.14
/wp-content/themes/scaffold/css/sidebar.css?ver=4.9.6
/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.9.6
/wp-content/plugins/wordpress-seo/css/dist/adminbar-1180.min.css?ver=11.8
/wp-content/plugins/wordpress-seo/css/dist/admin-global-1180.min.css?ver=11.8
/wp-content/plugins/wordpress-seo/css/dist/wpseo-dismissible-1180.min.css?ver=11.8
/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.8
/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.8.2
/wp-content/themes/scaffold/css/sidebar.css?ver=4.9.5
/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.9.4
/wp-content/themes/scaffold/css/sidebar.css?ver=4.9.2
/wp-content/plugins/wp-ultimate-csv-importer/assets/css/style-maintenance.css?ver=4.8
/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.8.1
/wp-content/themes/scaffold/css/sidebar.css?ver=4.9.4
/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.8
/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.9.4
/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.9.2
/wp-content/themes/scaffold/css/sidebar.css?ver=4.9.6
/wp-content/themes/scaffold/bootstrap/css/bootstrap_theme.min.css?ver=4.9.6
';
my $regex = qr/\.(css|js)\?ver=\d+\.\d\.*\d*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}