using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img\s+src=""(.*?)""\s+width=""(.*?)""\s+height=""(.*?)"">";
string input = @"<img src=""myurl.jpg"" width=""12"" height=""32"">";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}