$re = '/test\s*:\s*(.*)\./';
$str = 'test : match this.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);