re = /^\w+\.(?:jpg|png|gif)(?:, \w+\.(?:jpg|png|gif)){3}/
str = 'Chrysanthemum.jpg, Desert.png, Hydrangeas.gif, Jellyfish.jpg, Koala.jpg, Lighthouse.png,'
# Print the match result
str.match(re) do |match|
puts match.to_s
end