import Foundation
let pattern = ##"\[TYPECODE #1\](NCHG)\[MARF#\][^ ].*?\[EREF#\][^ ].*?\[IREF#\][^ ].*?\[RTRN#]\s.*?\[DR #1\][^ ]"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"[TYPECODE #1]NCHG[MARF#]006-0030705-000 [IBAN#] [NAME#] [EREF#]006-0030705-00020/07/2015 [IREF#]006-0030705-00020/07/2015 [PREF#] [SVCL#] [CSID#] [RTRN#] [OCMT#] [OTHR#] [ORDT#] [REMI#] [BIC#][DR #1]3.00"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}