$re = '/\b(?:[01][0-9]|2[0-3]):[0-5][0-9]\b/m';
$str = '00:00
12:20
23:59
34:45
100:234
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);