using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^abc.*_20150430\.txt$|^def.*_20150430\.txt$";
string input = @"abcteste_20150430.txt
defteste_20150430.txt";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}