re = /^abc.*_20150430\.txt$|^def.*_20150430\.txt$/m
str = 'abcteste_20150430.txt
defteste_20150430.txt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end