#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:[^,]*,){8})"?([^,"]*)"
Local $sString = "Home_TE,-2.8,1,"-",-,-,-,1,"-",-,-,-,"-",1,-,"-","-",-,-,MIL_TT" & @CRLF & _
"Home_TE,-2.8,1,"-",-,-,-,1,123,-,-,-,"-",1,-,"-","-",-,-,MIL_TT" & @CRLF & _
"Home_TE,-2.8,1,"-",-,-,-,1,456,-,-,-,"-",1,-,"-","-",-,-,MIL_TT"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")