#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!NIST-Privacy-v1\.1)(?!NIST-CSF-v1\.1).*-.*-.*[.-].*$"
Local $sString = "NIST-Privacy-v1.1" & @CRLF & _
"NIST-CSF-v1.1" & @CRLF & _
"AWS-CIS-v1.4-1.10" & @CRLF & _
"SOC-2-CC6.8" & @CRLF & _
"NIST-800-53rev5" & @CRLF & _
"NIST-800-53rev5-CM-3(1)" & @CRLF & _
"NIST-800-53rev5-AU-12(4)" & @CRLF & _
"SOC-2-CC6.1" & @CRLF & _
"NISTPrivacyFramework-v1.0" & @CRLF & _
"NISTPrivacyFramework-v1.0-PR.AC-P1" & @CRLF & _
"NIST-800-53rev5-AC-1" & @CRLF & _
"NIST-800-53rev5-IA-1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")