$re = '/\s*([\S]+)$/m';
$str = 'I would like to extract the last word of each line using regex. Most of the last words are built up like this:
alkj;asdf ;lkjasd f;lkj sjdjd AAAAB3NzaCLkc3M
asdf ajksdf ;lakjsdf ;lkjasdfAAAB3NzaCl/Ezfl
asdf sjadf asdkfj kjasdfAAAB3Nza/ClBAm+4lj
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);