$re = '/email=(\w+@\w+\.\w+)/';
$str = 'www.website.com/?email=test@gmail.com
www.website.com/?email=test@gmail.com&name=john
www.website.com/?name=john&email=test@gmail.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);