re = /\bvari?((?<=i)a)?((?<=a)b)?((?<=b)l)?((?<=l)e)?\b/
str = 'var name
vari name
varia name
variab name
variabl name
variable name
vard name
va name'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end