$re = '/(?<=\s)(?!\S*[#*])(?!\S*level[0-9])\S+/';
$str = 'How to write regex which find word (without whitespace) that doesn\'t contain some chars (like * or #) and sentence also (like level10 or level2 - it should be also regex - level[0-9]+). It will be simple for chars excluded ([^\\\\s^#^*]+) but how to exclude this \'level\' example too ?
I want to exclude chars AND level with number.
Examples:
weesdlevel3fv - shouldn\'t match because of \'level3\'
we3rlevelw4erw - should match - there is level without number
dfs3leveldfvws#3vd - shouldn\'t match - level is good, but \'#\' char appeared
level4#level levelw4_level - threat as two words because of whitespaces - only second one should match - no levels with number and no restricted chars like \'#\' or \'*\'';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;